I am a java dev. you already know it, or if not, just trust me, I am used to develop Java apps 🙂

So as a java developper, I am using Eclipse.

At Home, I am running Uuntu on all my laptops.

Eclipse Mars.2 does not work out of the box on this version !!!!!

To make it run smoothly, just edit your eclipse.ini:

-startup
plugins/org.eclipse.equinox.launcher_1.3.100.v20150511-1540.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.300.v20150602-1417
-product
org.eclipse.epp.package.jee.product
--launcher.defaultAction
openFile
-showsplash
org.eclipse.platform
--launcher.GTK_version
2
--launcher.defaultAction
openFile
--launcher.appendVmargs
-vmargs
-Dosgi.requiredJavaVersion=1.8
-Xms256m
-Xmx1536m

You must, just as in the ini file, swicth the

-Dosgi.requiredJavaVersion=1.7

to

-Dosgi.requiredJavaVersion=1.8

An set the

--launcher.GTK_version
2

An just before running eclipse, in your prefered terminal :

$> export SWT_GTK3=0

Then, just start eclipse :

$> eclipse

 

Capture d'écran de 2016-06-06 02-20-15
Eclipse mars.2 starting and running smoothly again !

Have Fun !

McG.

Publicités